osx - textlabels mit % und abspeichern der testeinstellung

osx - textlabels mit % und abspeichern der testeinstellung

Beitragvon Oliver Egger » 18.02.2008, 09:52

nach der installation der version 1.2 auf osx 10.4 erscheinen die labels mit % anstelle des deutschen textes wie %sidebar.cons... %sidebar.contacts etc und falls einstellungen in der testdatenbank gemacht weden (userprefs) sind diese bei einem neustart wieder leer, hat jemand dieses problem auch schon gesehen und/oder hat eine lösung dazu?
Oliver Egger
 
Beiträge: 3
Registriert: 24.01.2008, 19:47

Re: osx - textlabels mit % und abspeichern der testeinstellu

Beitragvon gweirich » 18.02.2008, 19:59

Oliver Egger hat geschrieben:nach der installation der version 1.2 auf osx 10.4 erscheinen die labels mit % anstelle des deutschen textes wie %sidebar.cons... %sidebar.contacts etc und falls einstellungen in der testdatenbank gemacht weden (userprefs) sind diese bei einem neustart wieder leer, hat jemand dieses problem auch schon gesehen und/oder hat eine lösung dazu?


Ich kann das hier (Mac OSX 10.4, Elexis 1.2.2) nicht nachvollziehen.
Grundsätzlich bedeutet das %label, dass die localization files nicht gefunden wurden (.properties).
Wo tritt dieses Problem denn auf? Können Sie einen Screenshot posten?
Welche Elexis-Version?
Die Testdatenbank ist nicht für produktiven Einsatz gedacht. Es gibt mysql auch für den Mac, das würde ich vorziehen.

Vielleicht kann Werner Trüb noch etwas dazu sagen, ob dieser Fehler auch bei ihm aufgetreten ist?
Oder gibt es noch andere Mac-User hier? (Ich selber verwende den Mac nur sehr sporadisch zum Arbeiten und merke deswegen solche Fehler nur, wen mich jemand mit der Nase draufstösst :) )
gweirich
 
Beiträge: 516
Registriert: 06.01.2008, 08:16
Wohnort: Schaffhausen

Re: osx - textlabels mit % und abspeichern der testeinstellu

Beitragvon Oliver Egger » 19.02.2008, 08:10

Herzlichen Dank für die Antwort

Welche Elexis-Version?

Elexis Verision 1.2.2 oxs angegeben auf der webseite unter http://www.elexis.ch/jp/index.php?optio ... view&id=57

Wo tritt dieses Problem denn auf? Können Sie einen Screenshot posten?


Das Problem tritt überall dort auf wo Texte via Labels angegeben werden (Präfrenzen, Menü) zum Beispiel:
Bild

Die Testdatenbank ist nicht für produktiven Einsatz gedacht. Es gibt mysql auch für den Mac, das würde ich vorziehen.


Ist für die Demo eines plugins, von dem her könnte ich mit der Testdatenbank gut leben.
Oliver Egger
 
Beiträge: 3
Registriert: 24.01.2008, 19:47

Re: osx - textlabels mit % und abspeichern der testeinstellu

Beitragvon gweirich » 19.02.2008, 17:44

Oliver Egger hat geschrieben:Bild


Sieht für mich (soweit ich das aus der Ferne erkennen kann) so aus, als habe dieser Mac ein nicht-deutschsprachiges Betriebssystem. Elexis versucht die englischen Lokalisierungsdateien zu laden und fällt dabei auf die Nase -offensichtlich sind diese Lokalisierungen noch nicht komplett.

Die Mac.Vesrion ist sicher am schlechtesten getestet und die nicht-deutschsprachigen Elexis-Lokalisierungen sind ebenfalls kaum getestet. Insofern gibt es da eine doppelte Stolperfalle und viel Entwicklungsbedarf.

Mögliche Abhilfe: in elexi.ini
-nl de_CH
eintragen, um Elexis zu zwingen, die Deutsche Lokalisierung zu verwenden
oder
alle .property-Files von _de nach _en kopieren.

Ist für die Demo eines plugins, von dem her könnte ich mit der Testdatenbank gut leben.

Wir reden hier aber nicht von einem DocBox-Plugin? 8)
gweirich
 
Beiträge: 516
Registriert: 06.01.2008, 08:16
Wohnort: Schaffhausen


Zurück zu Fragen zur Installation

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron