Covercard Plugin

Covercard Plugin

Beitragvon nicolas » 10.01.2008, 17:13

Ich erhalte folgende Fehlermeldungen:
wenn ich die Nummer manuell eingebe: java.lang.NoClassDefFoundError

über den Leser: An internal error occurred during "Covercard" java.long.ExceptonInInitializerError.

Elexis 1.2.1
Covercard Plugin 0.1.0

Was könnte der Grund sein?, Bin ich der Einzige mit dem Problem?
nicolas
 
Beiträge: 87
Registriert: 06.01.2008, 10:18

Re: Covercard Plugin

Beitragvon gweirich » 10.01.2008, 18:48

nicolas hat geschrieben:Ich erhalte folgende Fehlermeldungen:
wenn ich die Nummer manuell eingebe: java.lang.NoClassDefFoundError


Diese Fehlermeldung ist im Allgemeinen ein Symptom für einen Versionen-Konflikt: Ein Teil des Programms versucht auf einen anderen Teil zuzugreifen, der in dieser Version nicht existiert. (Eine genauere Eingrenzung des Fehlers wäre mit den Logfiles möglich)

Solche Probleme können auftreten, wenn unterschiedliche Versionen ins selbe Verzeichnis installiert wurden, oder wenn beim Auto-Update etwas schiefgegangen ist.

Abhilfe: Entweder die neueste Version von Elexis in einem separaten Verzeichnis installieren, oder das "features" und das "plugins"-Verzeichnis manuell reinigen. Das geht so:

Im features-Verzeichnis befindet sich (unter anderem) ch.elexis_1.2.1. Falls dort auch noch ein ch.elexis_1.2.0 oder noch älter existiert: Alle ausser den neuesten löschen. Die anderen Files nicht antasten.

Im plugins-Verzeichnis haben die Elexis-Plugins Namen wie:
ch.elexis.agenda_1.2.1_20080119 usw.

Auch hier gilt: Wenn mehrere mit demselben Basisnamen (also dem Teil vor der Versionsnummer) existieren, nur das jeweils neueste belassen und die anderen löschen. Wenn der Datumteil (oben 20080119) fehlt, dann ist es als älter zu betrachten,. als das gleichnamige mit Datumsteil.
gweirich
 
Beiträge: 516
Registriert: 06.01.2008, 08:16
Wohnort: Schaffhausen

Beitragvon nicolas » 11.01.2008, 07:19

[size=9]"Im features-Verzeichnis befindet sich (unter anderem) ch.elexis_1.2.1. Falls dort auch noch ein ch.elexis_1.2.0 oder noch älter existiert: Alle ausser den neuesten löschen. Die anderen Files nicht antasten.

Im plugins-Verzeichnis haben die Elexis-Plugins Namen wie:
ch.elexis.agenda_1.2.1_20080119 usw."
[/size]


Im plugin Verzeichnis waren tätsächlich verschieden Versionen nebeneinander vorhanden.
Aber im features Verzeichnis ist nur ch.elexis_1.2.0 vorhanden obwohl ich ein Update durchgeführt habe und im Programmfenster die korrekte Version 1.2.1 angezeigt wird.
nicolas
 
Beiträge: 87
Registriert: 06.01.2008, 10:18


Zurück zu Fehlerkorrekturen

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron