Ubuntu Lucid Lynx (10.04) - Elexis - OpenOffice

Ubuntu Lucid Lynx (10.04) - Elexis - OpenOffice

Beitragvon schawalder » 12.09.2010, 19:03

Ich beabsichtige in meiner Praxis alleinig mit Linux zu arbeiten. Nun bin ich am Austesten von Elexis mit dem neuesten LTS Ubuntu Release 10.04. Dieser Release kommt mit OpenOffice 3.2. Ich habe installiert:

openoffice.org 1:3.2.0-7ubuntu4.1
openoffice.org-base 1:3.2.0-7ubuntu4.1
openoffice.org-base-core 1:3.2.0-7ubuntu4.1
openoffice.org-calc 1:3.2.0-7ubuntu4.1
openoffice.org-common 1:3.2.0-7ubuntu4.1
openoffice.org-core 1:3.2.0-7ubuntu4.1
openoffice.org-draw 1:3.2.0-7ubuntu4.1
openoffice.org-emailmerge 1:3.2.0-7ubuntu4.1
openoffice.org-filter-binfilter 1:3.2.0-7ubuntu4.1
openoffice.org-filter-mobiledev 1:3.2.0-7ubuntu4.1
openoffice.org-impress 1:3.2.0-7ubuntu4.1
openoffice.org-java-common 1:3.2.0-7ubuntu4.1
openoffice.org-math 1:3.2.0-7ubuntu4.1
openoffice.org-officebean 1:3.2.0-7ubuntu4.1
openoffice.org-report-builder-bin 1:3.2.0-7ubuntu4.1
openoffice.org-style-galaxy 1:3.2.0-7ubuntu4.1
openoffice.org-writer 1:3.2.0-7ubuntu4.1

In Elexis habe ich die geforderten Einstellungen vorgenommen:
OpenOffice Wrapper
OOo-Programmverzeichnis: /usr/lib/openoffice/program
Installationspfad: /usr/lib/openoffice

Inhalt von elexis.ini
-vmargs
-Xms64m
-Xmx256m
-Djava.library.path=/usr/lib/openoffice/program

Aber: OpenOffice lässt sich nicht einbinden...
"Konnte TextView nicht erstellen
Das TestPlugin konnte nicht korrekt geladen werden"

Wie kann ich hier Abhilfe schaffen?

Gruss, Aaron Schawalder
schawalder
 
Beiträge: 69
Registriert: 11.09.2010, 12:34

Beitragvon marcode » 13.09.2010, 06:57

hallo,

welche version von Elexis willst du denn installieren/verwenden?
marcode
 
Beiträge: 42
Registriert: 19.04.2010, 17:16
Wohnort: Vorarlberg / Österreich

Beitragvon schawalder » 13.09.2010, 07:51

marcode hat geschrieben:hallo,

welche version von Elexis willst du denn installieren/verwenden?


aktuelle Version 1.4
schawalder
 
Beiträge: 69
Registriert: 11.09.2010, 12:34

Beitragvon marcode » 13.09.2010, 08:24

Von dieser Kombination ist abzuraten! Das OfficePlugin das dieser Version beiliegt funktioniert nicht korrekt mit Linux/Gnome, auch wenn das jetzt schätzovativ mit dem Fehler denn du siehst nichts zu tun hat!

Willst du 1.4 probieren, machs mit Windows .. sorry, bin auch ein starker Linux Freund ;)

lg

PS: Zur Info noch, die 1.4 ist nicht die aktuelle, sie ist nur die aktuelle version für die es downloads auf elexis.ch gibt. Die momentan aktuelle ist 2.1.1 (?)
marcode
 
Beiträge: 42
Registriert: 19.04.2010, 17:16
Wohnort: Vorarlberg / Österreich

Beitragvon gweirich » 13.09.2010, 08:56

Generell ist es bei Linux etwas komplizierter wegen der Vielzahl der Distributionen. Ich habe bei mir OpenOffice in Elexis 1.4 mit Xubuntu zum Laufen gekriegt. Mit Gnome geht die Integration grundsätzlich nicht.
Es ist aber immer ein gewisses Experimentieren.

Medelexis verspricht, dass Elexis 2.1/OpenOffice 3.2 mit ihrem kommerziellen Text-Plugin unter SuSe funktioniert. Bei mir geht auch dies mit Xubuntu/xfce und Kubuntu/KDE.

Elexis 1.4 empfehle ich eigentlich nicht mehr. Entweder man kompiliert sich eine freie 2.1er Version aus dem Repository, oder man nimmt ein Medelexis-Abonnement.
gweirich
 
Beiträge: 516
Registriert: 06.01.2008, 08:16
Wohnort: Schaffhausen

Beitragvon schawalder » 13.09.2010, 11:54

gweirich hat geschrieben:Generell ist es bei Linux etwas komplizierter wegen der Vielzahl der Distributionen. Ich habe bei mir OpenOffice in Elexis 1.4 mit Xubuntu zum Laufen gekriegt. Mit Gnome geht die Integration grundsätzlich nicht.
Es ist aber immer ein gewisses Experimentieren.

Das kann ich mir vorstellen.

gweirich hat geschrieben:Medelexis verspricht, dass Elexis 2.1/OpenOffice 3.2 mit ihrem kommerziellen Text-Plugin unter SuSe funktioniert. Bei mir geht auch dies mit Xubuntu/xfce und Kubuntu/KDE.

Elexis 1.4 empfehle ich eigentlich nicht mehr. Entweder man kompiliert sich eine freie 2.1er Version aus dem Repository, oder man nimmt ein Medelexis-Abonnement.


Wo finde ich denn das Repository? Hab den Link leider noch nicht finden können. Ist das "kommerzielle Text-Plugin" in 2.1 enthalten?
schawalder
 
Beiträge: 69
Registriert: 11.09.2010, 12:34

Beitragvon gweirich » 13.09.2010, 12:09

Repositories: Open Source, Eclipse Public License.
http://elexis.hg.sourceforge.net/hgweb/elexis bzw.
http://sourceforge.net/projects/elexis/

Kommerzielle Plugins: Vom Hersteller kompiliert und zu dessen Bedingungen zu beziehen. Im Fall des OpenOffice-Plugins: Medelexis AG, Baden.
gweirich
 
Beiträge: 516
Registriert: 06.01.2008, 08:16
Wohnort: Schaffhausen

Beitragvon schawalder » 13.09.2010, 15:00

gweirich hat geschrieben:Repositories: Open Source, Eclipse Public License.
http://elexis.hg.sourceforge.net/hgweb/elexis bzw.
http://sourceforge.net/projects/elexis/


Da finde ich aber den 2.1er Release nicht?
schawalder
 
Beiträge: 69
Registriert: 11.09.2010, 12:34

Beitragvon gweirich » 13.09.2010, 18:37

elexis-base und elexis-addons sind immer auf dem neuesten Stand ("bleeding edge"). Das ist zur Zeit 2.1.2. Frühere Stände seit 2.0 sind als Branches oder Tags im Repository enthalten. 1.4 und 2.0 sind nur aus historischen Gründen in separaten Repositories.
gweirich
 
Beiträge: 516
Registriert: 06.01.2008, 08:16
Wohnort: Schaffhausen

Beitragvon schawalder » 14.09.2010, 07:01

Ich hänge leider fest...
Ich versuche mir Eclipse einzurichten (Xubuntu Lucid Lynx). Ich habe
- Eclipse IDE for Java EE Developers (Helios) installiert,
- gemäss First Steps das mercurial client plugin (http://cbes.javaforge.com/update) nachinstalliert. ("Check everything except 'Obsolete'and uncheck 'Windows Binaries for Mercurial' listed under MercurialEclipse (if you are not running Windows). Then Next, Next, Accept, Finish, OK and finally we can click 'Yes' to restart")

Nun kommt wie in http://code.google.com/p/voa-web2py2ecl ... eoOnOsx104 erwähnt die Fehlermeldung "hg -y debuginstall hg not found".

Leider kann ich einfach hg nirgends finden. Ein "locate hg" z.B. findet kein hg.

Habe ich da etwas vergessen?
schawalder
 
Beiträge: 69
Registriert: 11.09.2010, 12:34

Beitragvon gweirich » 14.09.2010, 07:25

http://elexis-forum.ch/viewtopic.php?t=306

(hg selbst ist im Plugin nicht enthalten)

Und lieber die Eclipse IDE for RCP and RAP Developers nehmen.
gweirich
 
Beiträge: 516
Registriert: 06.01.2008, 08:16
Wohnort: Schaffhausen

Beitragvon schawalder » 14.09.2010, 13:30

gweirich hat geschrieben:http://elexis-forum.ch/viewtopic.php?t=306

(hg selbst ist im Plugin nicht enthalten)

Und lieber die Eclipse IDE for RCP and RAP Developers nehmen.


Herzlichen Dank. Jetzt hat es geklappt mit dem clonen. Ist alles noch neu für mich, da ich noch nie mit Eclipse gearbeitet habe und ich sonst für Programmierungen stets C++ verwendete mit einer anderen IDE.
Ich hoffe, ich komme nun weiter ...
schawalder
 
Beiträge: 69
Registriert: 11.09.2010, 12:34

Beitragvon schawalder » 15.09.2010, 16:24

Ich möchte gerne einen Überblick über die vielen Plugins erhalten. Wie kann ich da vorgehen? Gibt es eine Doku dazu oder bleibt mir nichts anderes übrig als jeweils die READMEs etc. zu lesen?

Gruss, Aaron Schawalder
schawalder
 
Beiträge: 69
Registriert: 11.09.2010, 12:34

Beitragvon gweirich » 16.09.2010, 04:26

Die Dokumentation ist spärlich. Aber es ist durchaus erlaubt, sie zu erweitern und zu verbessern :wink:

im Plugin elexis-developer-resources gibt es nebst Dokumentation auch Beispielcode und hier stehen auch noch ein paar infos http://www.elexis.ch/jp/content/blogcategory/21/53/
gweirich
 
Beiträge: 516
Registriert: 06.01.2008, 08:16
Wohnort: Schaffhausen

Beitragvon schawalder » 16.09.2010, 07:39

gweirich hat geschrieben:Die Dokumentation ist spärlich. Aber es ist durchaus erlaubt, sie zu erweitern und zu verbessern :wink:


Tja, soweit bin ich leider noch nicht. Allenfalls würde ich später gerne einmal ein Plugin beisteuern ... nur, im Moment ist noch so vieles neu für mich, dass ich stets wieder steckenbleibe. Ich habe es noch nicht geschafft, Elexis in Eclipse zu starten. Es kommen Fehlermeldungen. Dazu kommt, dass ich in der Bedienung von Eclipse noch ein Anfänger bin und vieles noch nicht verstehe.
Nun könnte ich natürlich ein Medelexis-Abo nehmen... Das möchte ich eigentlich nicht, da ich im OpenSource-Bereich bleiben und wenn schon mich selber damit auskennen möchte. Sonst könnte ich auch ein Vitodata-Abo für Vitomed nehmen.
Wie kann ich im Eclipse-Dschungel vorgehen, damit ich das Basiswerkzeug verstehe, um überhaupt einmal eine Elexis-Version kompilieren/exportieren zu können?

Eine weitere Frage:
Gibt es einen Grund, weshalb auf der Homepage im Download-Bereich keine aktuelle Version zum Download bereitgestellt wird?
schawalder
 
Beiträge: 69
Registriert: 11.09.2010, 12:34

Nächste

Zurück zu Fragen zur Installation

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron